Configuração de topologia OSPF e protocolo de camada 3 redundância HSRP.

 

Configuração de topologia OSPF e protocolo de camada 3 redundância HSRP.

Um tópico do CCNP, agora é curriculum do CCNA, e para vocês que desejam testar esse protocolo de redundância de Gateway Proprietário Cisco ai esta uma topologia para fazer os testes.

Após configurar o endereço IP na interface, use o comando standby group-number ip ip-address para reconfigurar o HSRP.

Em HSRPv1, o número de grupo pode ser qualquer valor entre 0 e 255, mas deve ser o mesmo em ambos os roteadores vizinhos. Em HSRPv2, o número de grupo pode ser qualquer valor entre 0 e 4095.

O endereço IP é o endereço IP do roteador virtual para o grupo HSRP. Ele deve ser idêntico em todos os roteadores de um mesmo grupo HSRP.

Cada grupo de espera tem seus próprios ativos e roteadores standby. Um engenheiro de rede pode atribuir um valor de prioridade a cada roteador de um grupo de espera, controlando, dessa forma, a ordem na qual os roteadores ativos do grupo serão selecionados. O valor padrão é 100, mas pode ser de 0 a 255.

Durante o processo de seleção, o roteador com maior prioridade em um grupo HSRP se torna o roteador ativo. Se um vínculo ocorrer, o roteador com o maior endereço IP configurado se tornará ativo.

Se os roteadores não estão configurados com preempt, um roteador que se inicializar de modo significativamente mais rápido do que os outros do grupo de espera, se tornará o roteador ativo, independentemente da prioridade configurada. O antigo roteador ativo pode ser configurado para retomar a função de roteador de encaminhamento ao assumir o lugar de um roteador com prioridade mais baixa.

Vamos a nossa topologia.

 topologia

Configuração ISP

ISP>enable

ISP#configure terminal

ISP(Config)#interface serial 0/0/0

ISP(config-if)#ip address 20.0.0.1 255.255.255.252

ISP(config-if)#clock rate 64000

ISP(config-if)#no shutdown

ISP(config-if)#exit

ISP(config)#interface serial 0/0/1

ISP(config-if)#ip address 20.0.0.5 255.255.255.252

ISP(config-if)#clock rate 64000

ISP(config-if)#no shutdown

ISP(config-if)#exit

ISP(config)#router ospf 1

ISP(config-router)#network 20.0.0.0 0.0.0.3 area 0

ISP(config-router)#network 20.0.0.4 0.0.0.3 area 0

ISP(config-router)#exit

ISP(config)#exit

ISP#copy running-config startup-config

Configuranção Operadora_2

Operadora_2>enable

Operadora_2#configure terminal

Operadora_2(config)#interface serial 0/0/0

Operadora_2(config-if)#ip address 20.0.0.2 255.255.255.252

Operadora_2(config-if)#no shutdown

Operadora_2(config-if)#exit

Operadora_2(config)#interface fastethernet 0/0

Operadora_2(config-if)#ip address 10.10.10.10 255.255.255.0

Operadora_2(config-if)#no shutdown

Operadora_2(config-if)#exit

Operadora_2(config)#router ospf 1

Operadora_2(config-router)#network 20.0.0.0 0.0.0.3 area 0

Operadora_2(config-router)#network 10.10.10.0 0.0.0.255 area 0

Operadora_2(config-router)#exit

Operadora_2(config)#exit

Operadora_2#copy running-config startup-config

Operadora_2#

Configuração Operadora_1

Operadora_1>enable

Operadora_1#configure terminal

Operadora_1(config)#interface serial 0/0/0

Operadora_1(config-if)#ip address 20.0.0.6 255.255.255.252

Operadora_1(config-if)#no shutdown

Operadora_1(config-if)#exit

Operadora_1(config)#interface fastethernet 0/0

Operadora_1(config-if)#ip address 10.10.10.11 255.255.255.0

Operadora_1(config-if)#no shutdown

Operadora_1(config-if)#exit

Operadora_1(config)#router ospf 1

Operadora_1(config-router)#network 20.0.0.4 0.0.0.3 area 0

Operadora_1(config-router)#network 10.10.10.0 0.0.0.255 area 0

Operadora_1(config-router)#exit

Operadora_1(config)#exit

Operadora_1#copy running-config startup-config

Operadora_1#

Configurando HSRP Operadora_1

Operadora_1#configure terminal

Operadora_1(config)#interface fastethernet 0/0

Operadora_1(config-if)#standby 1 ip 10.10.10.12

Operadora_1(config-if)#standby 1 priority 110 (a prioridade 110 garante o roteador Operadora_1 como Ativo, a prioridade padrão é 100)

Operadora_1(config-if)#standby 1 preempt (garante o roteador operadora_1 seja o HSRP pelo tempo que sua interface permanecer ativa enviando hello)

Operadora_1(config-if)#exit

Operadora_1(config)#exit

Operadora_1#copy running-config startup-config

Configurando HSRP Operadora_2

Operadora_2#configure terminal

Operadora_2(config)#interface fastethernet 0/0

Operadora_2(config-if)#standby 1 ip 10.10.10.12

Operadora_2(config-if)#standby 1 priority 90 (a prioridade 90 garante o roteador Operadora_2 como standby, a prioridade padrão é 100)

Operadora_2(config-if)#standby 1 preempt

Operadora_2(config-if)#exit

Operadora_2(config)#exit

Operadora_2#copy running-config startup-config

 

Configuração PC1

IP: 10.10.10.50

mascara: 255.255.255.0

Gateway: 10.10.10.12

Até o próximo post!!!

Anúncios
Publicado em Routing por batistaangelo10. Marque Link Permanente.

Sobre batistaangelo10

* Profissional de Redes com mais de 7 anos de experiencia, certificado CCNP R&S Cisco, estudando para certificações CCDA e CCNA Security. * Gosto de ler livros relacionado a tecnologias cisco, Atualmente estou lendo o livro CCDA 200-310 Ciscopress. * Finais de semana ando de skate para renovar as energias da semana.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s