Espelhamento de Portas com SPAN e RSPAN.

Bom dia, Galera.

Como fazer monitoramento de portas para verificar trafego em sua rede cisco? Em versões mais atuais da IOS cisco existe o SPAN (Switch Port Analyzer) que é muito útil para realizar troubleshoot de problemas na rede, levando em consideração que as redes de hoje em dia não permite tempo de parada para realizar esses procedimentos. Porem antes de realizar esse procedimento, de acordo com os padrões cisco, é necessário dimensionar bem o espelhamento de trafego, para não causar lentidão na rede, uma vez que se for monitorar o trafego de uma rede inteira em uma única porta pode subir o processamento de CPU do switch.  Vamos a configurações:

 

 

 

 

SW01# configure terminal
SW01(config)# monitor session 1 source interface gi0/0
SW01(config)# monitor session 1 destination interface gi0/1
SW01(config)# end
SW01# copy running-config startup-config

Para o RSPAN seguimos o mesmo procedimento que o SPAN, porem enviamos o trafego para uma vlan que criamos nos 2 switchs que ira participar do procedimento, RSPAN (Remote switch port analizer), vamos a configuração:

 

 

 

 

!! Criando vlan para espelhar o trafeto, servira como transito para o espelhamento
!! note que adicionamos o comando remote span.
SW01(config)# vlan 50
SW01(config-vlan)# name VLAN-RSPAN
SW01(config-vlan)# remote span
SW01(config-vlan)# exit

!! Não esquecer as configurações de Truk entre os switchs, acredito
!! que nesse ponto já exista em sua rede.
SW01(config)# interface g0/2
SW01(config-if)# switchport mode trunk
SW01(config-if)# exit

!! Configuração de span, as portas que serão monitorada com o comando source ira direcionar
!! o trafego para a vlan criada.
SW01(config)# monitor session 1 source interface gi0/0
SW01(config)# monitor session 1 destination remote vlan 50

!! Config switch 2
!! Criando vlan para receber o trafego espelhado.
SW02(config)# vlan 50
SW02(config-vlan)# name VLAN-RSPAN
SW02(config-vlan)# remote span – Em alguns modelos de IOS esse comando so é suportado do lado que ira coletar o trafego.
SW02(config-vlan)# exit

!! Não esquecer de validar o trunk entre os switchs.
SW02(config)# interface g0/2
SW02(config-if)# switchport mode trunk
SW02(config-if)# exit

!! Criando sessao monitor.
SW02(config)# monitor session 1 source remote vlan 50
SW02(config)# monitor session 1 destination interface gi0/1

Para captura dos pacotes podem usar analisadores de pacote, EX: Wireshark

Espero ter ajudado, bons estudos e até o próximo post!!!

 

 

 

Anúncios

Configuração inter-vlan em router e switch Multilayer

INTER-VLAN ROUTE
Configurando interface do roteador para fazer o roteamento das vlans na rede, também conhecido como inter-vlan.
Configurando sub-interface do router.
!
interface FastEthernet0/0
description ### Lan InterVlan ###
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
Configurando portas do switch em modo access para permitir o dispositivo trafegar na rede vlan.
!
interface FastEthernet0/1
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
switchport nonegotiate
!
PC1
Ip address 192.168.10.10
Mascara 255.255.255.0
Gatway 192.168.10.1
PC2
Ip address 192.168.20.10
Mascara 255.255.255.0
Gatway 192.168.20.1

#############################################

INTER-VLAN MULTILAYER SWITCH
Configurando roteamento inter-vlan no Multilayer switch.
Config_Switch Multilayer
!
ip routing
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport port-security mac-address sticky
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
switchport nonegotiate
switchport port-security mac-address sticky
!
Criar vlans antes de configurar a interface SVI
!
Vlan10
!
Vlan20
!
interface Vlan10
description ### Lan Vlan 10 ###
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
description ### Lan Vlan 20 ###
ip address 192.168.20.1 255.255.255.0
!
PC1
Ip address 192.168.10.10
Mascara 255.255.255.0
Gatway 192.168.10.1
PC2
Ip address 192.168.20.10
Mascara 255.255.255.0
Gatway 192.168.20.1

Até o próximo post e bons estudos!!!

Configuração Inter Vlan com domínio VTP

Nota

Configuração Inter Vlan com domínio VTP

Tópico muito interessante do CCNA e que é muito cobrado na prova, além dos conceitos que é muito importante na hora da prova, segue configurações básicas para VLAN e com domínio VTP para facilitar a configuração de VLANs em Switchs.

configuracao vlan com dominio vtp

 

 

 

 

 

 

 

Configuração de VTP nos Switchs

Switch 1

Sw1#configure terminal

Sw1(config)#vtp mode server

Sw1(config)#vtp domain CVTP

Sw1(config)#vtp password cisco

Sw1(config)#vlan 10

Sw1(config)#vlan 20

Sw1(config)#vlan 30

Sw1(config)#vlan 99

Sw1(config)#exit

Sw1#copy running-config startup-config

[OK]

Sw1#

Switch 2
Continuar lendo

Comandos e Configurações CISCO (Incluindo configuração de vlan)

Fellipe Nobre

Salve galera!!

Recentemente precisei criar vlans em um Switch Cisco e encontrei certa dificuldade para encontrar um material para “iniciante”, pois a maioria dos tutorias/dicas somente abordam o resultado e os comandos finais e nem sempre mostram o caminho ate chegar neles. Então resolvi montar um “frankenstein”, pegando um conhecimento daqui, um tutorial ali, uma dica acula e voilá…

Abaixo seguem algumas dicas legais:

1- Entrar no modo privilegiado:

switch>enable

Password:*******

switch#

2- Configurar ou alterar a senha do modo privilegiado:

switch# config t

switch(config)#enable secret ****** digite a senha

switch(config)#exit

3- Configurar um nome para o Switch:

switch#configure terminal

switch(config)#hostname NOME

switch(config)#exit

switch#

4- Configurar velocidade e modo de comunicação da porta:

Switch 2950:

switch#config t

switch(config)#interface fastEthernet 0/1

switch(config-if)#speed 100

switch(config-if)#duplex full

5- Configurar o endereço IP/Máscara/Gateway nos Switches:

switch#configure terminal

switch(config)#interface vlan 1

switch(config-if)#ip address X.X.X.X Y.Y.Y.Y onde X é o endereço IP e Y a máscara…

Ver o post original 696 mais palavras