Captura de Pacotes .pcap Local em IOS cisco.

Boa tarde, Caros leitores.

Imagino que já tiveram problemas na hora de realizar uma analise na rede?

Falta de portas para conectar um notebook e fazer captura de pacotes?

Ou no caso de um troubleshoot remoto, como fazer para ter essas informações na mão?

Temos respostas para essa pergunta, Captura de pacotes .pcap local em IOS cisco.

Como funciona essa tecnologia? Informações retiradas do site da cisco, Quando permitido, o roteador captura os pacotes enviados e recebidos. Os pacotes são armazenados dentro de um buffer no DRAM e não são assim persistentes através de um reload. Uma vez que os dados são capturados, podem ser examinados em um sumário ou em uma vista detalhada no roteador. Além, os dados podem ser exportados como um arquivo da captura de pacote de informação (PCAP) para permitir um exame mais adicional. A ferramenta é configurada no modo exec e considerada uma ferramenta provisória do auxílio. Em consequência, a configuração da ferramenta não é armazenada dentro da configuração de roteador e não permanecerá no lugar após um recarregamento do sistema”

Como configurar?  Exemplo de configuração em IOS.

Configuração básica do EPC

  1. Defina da “um buffer captação”, que seja um buffer provisório que os pacotes capturados estão armazenados dentro. Há as várias opções que podem ser selecionadas quando o buffer é definido; como o tamanho, o tamanho do pacote do maxium, e o circular/o Linear:
    monitor capture buffer BUF size 2048 max-size 1518 linear
  2. Um filtro pode igualmente ser aplicado para limitar a captação ao tráfego desejado. Defina um Access Control List (ACL) dentro do modo de configuração e aplique o filtro ao buffer:
    ip access-list extended BUF-FILTER
        permit ip host 192.168.1.1 host 172.16.1.1
        permit ip host 172.16.1.1 host 192.168.1.1
    monitor capture buffer BUF filter access-list BUF-FILTER
  3. Defina da “um ponto captação”, que defina o lugar onde a captação ocorre. O ponto da captação igualmente define se a captação ocorre para o IPv4 ou o IPv6 e em que trajeto de switching (processo contra o cef):
    monitor capture point ip cef POINT fastEthernet 0 both
  4. Anexe o buffer ao ponto da captação:
    monitor capture point associate POINT BUF
  5. Comece a captação:
    monitor capture point start POINT
  6. A captação é agora ativa. Permita a coleção dos dados necessários.
  7. Pare a captação:
    monitor capture point stop POINT
  8. Examine o buffer na unidade:
    show monitor capture buffer BUF dump

    Nota: Esta saída mostra somente a cópia parcial da memória de HEX das captações dos pacotes. A fim ver em compreensível para o utilizador lá são duas maneiras.

    1. Exporte o buffer do roteador para a análise mais aprofundada:
      monitor capture buffer BUF export tftp://10.1.1.1/BUF.pcap

      Dica: A requisição de aprimoramento CSCuw77601 foi arquivada a fim adicionar a correio-à opção sob a exportação assim que você pode enviar por correio eletrónico o buffer diretly a uma email-identificação.

    2. Contudo o método anterior não é sempre prático como ele exigiu o acesso T/FTP ao roteador. Em tais situações, você pode tomar uma cópia da cópia parcial da memória de HEX e para usar todo o em linha encantar-pcap o conversor a fim ver os arquivos.
  9. Uma vez que os dados necessários foram recolhidos, suprima da “do ponto captação” e “capture o buffer”:
    no monitor capture point ip cef POINT fastEthernet 0 both
    no monitor capture buffer BUF

Continuar lendo

Anúncios

INSTALAÇÃO UNETLAB / EVE-NG

Vídeo

Boa tarde, Galera!!

Não poderia deixar de re-blogar esse material único, vocês que gostam de simuladores de redes já comentei de alguns aqui no blog, porem sem duvidas esse é um dos melhores que já tive a oportunidade de usar, troubleshoot muito fácil e podem utilizar outros vendors como HP, Fortnet, Juniper, Cisco, Palo Auto, Mikrotik e outros diversos… você não pode deixar de ver esse material.

Para realizar a Instalação primeiro vá até o site da EVE UnetLab: http://www.eve-ng.net faça o download do EVE e siga a instalação de acordo com o link a baixo:
https://ipsla.blogspot.com.br/2016/10/instalacao-unetlab.html

Bons estudos e até o próximo post!!!

Espelhamento de Portas com SPAN e RSPAN.

Bom dia, Galera.

Como fazer monitoramento de portas para verificar trafego em sua rede cisco? Em versões mais atuais da IOS cisco existe o SPAN (Switch Port Analyzer) que é muito útil para realizar troubleshoot de problemas na rede, levando em consideração que as redes de hoje em dia não permite tempo de parada para realizar esses procedimentos. Porem antes de realizar esse procedimento, de acordo com os padrões cisco, é necessário dimensionar bem o espelhamento de trafego, para não causar lentidão na rede, uma vez que se for monitorar o trafego de uma rede inteira em uma única porta pode subir o processamento de CPU do switch.  Vamos a configurações:

 

 

 

 

SW01# configure terminal
SW01(config)# monitor session 1 source interface gi0/0
SW01(config)# monitor session 1 destination interface gi0/1
SW01(config)# end
SW01# copy running-config startup-config

Para o RSPAN seguimos o mesmo procedimento que o SPAN, porem enviamos o trafego para uma vlan que criamos nos 2 switchs que ira participar do procedimento, RSPAN (Remote switch port analizer), vamos a configuração:

 

 

 

 

!! Criando vlan para espelhar o trafeto, servira como transito para o espelhamento
!! note que adicionamos o comando remote span.
SW01(config)# vlan 50
SW01(config-vlan)# name VLAN-RSPAN
SW01(config-vlan)# remote span
SW01(config-vlan)# exit

!! Não esquecer as configurações de Truk entre os switchs, acredito
!! que nesse ponto já exista em sua rede.
SW01(config)# interface g0/2
SW01(config-if)# switchport mode trunk
SW01(config-if)# exit

!! Configuração de span, as portas que serão monitorada com o comando source ira direcionar
!! o trafego para a vlan criada.
SW01(config)# monitor session 1 source interface gi0/0
SW01(config)# monitor session 1 destination remote vlan 50

!! Config switch 2
!! Criando vlan para receber o trafego espelhado.
SW02(config)# vlan 50
SW02(config-vlan)# name VLAN-RSPAN
SW02(config-vlan)# remote span – Em alguns modelos de IOS esse comando so é suportado do lado que ira coletar o trafego.
SW02(config-vlan)# exit

!! Não esquecer de validar o trunk entre os switchs.
SW02(config)# interface g0/2
SW02(config-if)# switchport mode trunk
SW02(config-if)# exit

!! Criando sessao monitor.
SW02(config)# monitor session 1 source remote vlan 50
SW02(config)# monitor session 1 destination interface gi0/1

Para captura dos pacotes podem usar analisadores de pacote, EX: Wireshark

Espero ter ajudado, bons estudos e até o próximo post!!!

 

 

 

Laboratorio NAT Sim CCNA 200-125

Vídeo

Boa tarde, Galera.

Segue mais um video sobre laboratório NAT – Prova CCNA R&A 200-125.

A baixo segue configuração para o lab.

! Access list permindo o IP privado
!
access-list 1 permit 192.168.100.16 0.0.0.15
!
! Nat pool par ao range disponibilizado pela operadora
!
ip nat pool mypool 198.18.184.105 198.18.184.110 netmask 255.255.255.248
!
! Integrando a access list criada e o nat pool
!
ip nat inside source list 1 pool mypool overload
!
! Interface que sera inserida o NAT inside e outside
!
inteface Fastethernet0/0
ip nat inside
!
!
interface Serial0/0
ip nat outside
!
! Comando para verificar a tradução do NAT
!
show ip nat translations
!

! Realizar ping para o ip do IPS

Bons estudos!!!